Macbook connection to CoDrone

  • Hi There,

    We have the issue to connect the controller board from Macbook, we have installed the Mac_OSX_VCP_Driver and latest version of snap!. But it seems the Macbook cannot detect the Bluetooth controller board.

    Can you advise what is the latest procedure for Mac OS connect and code the Codrone? Use Chrome ext.? Thanks!


  • We will try and let you know soon. Thanks!

  • @dc1500 Were you able to test if switching to "developer mode" worked?

  • @dc1500 Sorry we weren't able to get to your issue in time. Were you able to get the .crx installed? We've found that when you go to "chrome://extensions" and set the browser to "Developer mode" in the top right, that seems to help with the issue.

    Please let me know if that helps. Again, apologies for the slow response, we've been at ISTE over the last week, and our staff has been busy with summer camps as well.

  • Ohhh, I see! We were seeing that issue in our classrooms as well for Mac users occasionally. For some reason, the behavior seemed random. Basically, if you don't see a "Drop to install" icon overlay the "chrome://extensions" window when you're dragging into the browser and haven't dropped yet, then it's most likely not working.

    I'll need to further troubleshoot to see why that issue happens, so please hang tight.

  • Hello,

    I was able to download the Chrome app but when I tried installing the extension, I was not allowed to drag and drop the .crx file into the chrome extensions page. Every time I try to drag and drop it, it redownloads the zip file and it does not appear on the apps page.

    The camp will start next week.

    Thank you.

  • Hi @dc1500! We can help you out, though we may be a little slower in the next week, since much of our team is at the ISTE conference or running a summer camp. For the machines where you were able to get the Chrome app installed, can you tell me if you're running version 1.1.4 of the Chrome app? You can check by going to "chrome://extensions" and clicking "Details."

    Also, for the .crx installation, can you share a screenshot or video of what happens and explain in a bit more detail? Lastly, when is the camp happening, so I can determine if doing a video call is possible with our schedule.

  • Hello, I am currently having some trouble connecting to the codrone Lite. I have installed the Snap! software for Mac and bluetooth board driver on several macs and have not been successful in connecting to the drone. When selecting the Codrone option and trying to connect to the drone, I receive a message that informs me that no boards can be found and it is unable to connect to a device. I have also tried installing the chrome app extension and was not allowed to drag and drop the .crx file into the chrome extensions page. We have had some success in connecting to the drone using a PC computer, but the students that will be working with the drones will be using Macs. Can you help us troubleshoot this issue? Thank you.

  • Hi @rchan1030, just checking in with you. Any luck yet? Let me know if there's any way we can help.

  • Sounds like it might be an issue particular to Mac.

    Can you give the Chrome app a go? We're still trying to find what all the hardware inconsistencies are between machines, so we do see some inconsistency between which hardware supports which platform. I'd recommend trying the Chrome app, since we're able to debug that more quickly once we find a pattern.

  • We are using the native SNAP! application. Do you suggest we'd better using Chrome app? The BLE board is working fine under Windows environment. Just cannot solve it in MacBook.

  • Hi @rchan1030. Are you using the native application, or are you using the Chrome app?

    A few things to try are also to try switching to another USB port. I'm assuming you've already made sure the BLE board's light is blinking red when you try to connect, as well. Also, if you have another BLE board, see if you're experiencing the same issue. If you're having trouble after all those steps, we can set up a call with @robolink_arnold to see if the board is defective, which can happen sometimes. If so, we can arrange a replacement.

Log in to reply

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.