CoDrone Lite problems

  • Hello! I have gone through to some of the exercises in the provided lessons, and I had some issues.

    1. My drone disconnects after I run every program. The lights of the drone turn off, and I have to reconnect again to the computer. Is this normal? I thought it could be a battery problem, but I checked the percentage, and it was around 70%

    2. My drone flights all over the place. I checked this page given that every time I was trying to execute a program, my drone flew to the ceiling, even after setting the trim, the drone keeps moving all over the place.

    These are my first concerns, thank you in advance for your help 🙂

  • @elisaheinrich Ah, gotcha! Were you able to update the CoDrone's firmware to 50.18? That's step #3 in the Updating CoDrone.

    Also, did you try using the "zero-out" blocks I sent in the previous message? Try putting those blocks together, then clicking those as they're linked together a few times so it "zeroes out" the variables.

    As I mentioned, updating the firmware to 50.18 will also work, and it's the more permanent solution.

    Also, can you confirm that calibration has been working? As in, it takes off, hovers for 5 seconds, and lands?

    Give it a shot, and let me know if it helps!

  • @robolink_wes Hi! Sorry, I have the CoDrone Lite. I am currently using the RokitBrick CoDrone 1.1.3 Beta, the one that is indicated in the Getting Started part.

  • @elisaheinrich Hmmmm, can you check the firmware version? It should say at the top of the Snap Chrome app when you've paired with the drone. Are you on 50.18? You can check (and upgrade) by downloading the "Petrone" app, which is an app that our partner created just for flying the drone. That's covered in step #3 in this lesson.

    The earlier firmware versions sometimes have an issue with not zeroing out after you run a flight sequence and hit the killswitch. For example, if you have throttle set to 70, and hit the killswitch, then run that same block flight sequence again, the 70 carries over.

    Alternatively, you can also programmatically zero out by creating a zero out block, and click it a couple times to make sure it sends properly. I'd use:
    [roll: 0]
    [pitch: 0]
    [yaw: 0]
    [throttle: 0]
    [send command]

    If you put those blocks together, and then click it a couple times before you fly again, that should make sure to zero-out the variables before you fly again. Firmware version 50.18 does this automatically.

  • @robolink_wes Hi! Sorry to bother you again. So today I calibrated the drone, seemed that everything was going fine. I tried one of the block codes from the lesson "Conditionals in flight", the first time I ran it, it worked perfectly. The second time, it flew directly to the ceiling again. I tried to re-calibrate it, and it flew all over the place hitting the ceiling and the wall in the calibrating flight. Do you know what it can be?

  • This post is deleted!

  • For now, avoid running the request block, unless you absolutely need to check the battery percentage.

    The only way to stop the background request at the moment is to restart Snap. We'll make sure the bug is resolved in the next release.

  • @robolink_wes This makes totally sense! Thank you so much for your help! Will keep an eye on it, and if it happens again will let you know. Thank you again!

  • Y'know what, we did find a bug just recently that is caused by the request block, specifically for BATTERY_PERCENTAGE. It checks the battery percentage, but continues checking (behind the scenes) even after you've stopped and deactivated the block. So if you see that the BLE board is flashing multi-color even when you aren't actually trying to send commands to it, that means that is happening. The kicker is once you try to run any other code while that bug happens (i.e. the board is still blinking multi-color even when you aren't running commands), it will overload and shut the board off, which obviously causes the CoDrone to disconnect.

    We're currently fixing that bug so that the next version of the Chrome app doesn't have that bug. It sounds like that may be the bug that's causing that to happen.

  • Thank you so much for your quick response.

    I am not sure what can be, now I am trying it again and it seems to work normally (but I am not crazy haha). Last week, I was selecting really simple block codes, like taking off and landing, and once I ran the code once, it seems that the drone disconnects after that, because even if I click the same program, the drone didnt respond. Maybe the battery is old?

  • @elisaheinrich Welcome to the community, and sorry to see you're having issues!

    Can you take a screenshot of the block code you're running that causes the drone to shut off? The drone shutting off seems unusual, so I want to see if there's anything in the code that might be causing it.

    For the drone flying all over the place, it sounds like you may need to do a calibration, which is detailed in the calibration tutorial. The page you linked is old content, so it may be a bit outdated.

    Also, make sure to check that all the motors, propellers, shells, and guard are attached tightly, and there aren't any hairs caught in the propellers.

Log in to reply

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.