Mac Sierra and High Sierra Support

  • I've been troubleshooting a problem during my free time for the last week with my new-out-of-the-box CoDrone Pro. Followed all the steps to upload software but can't get past connecting to the BLE board (I have "V.17B"). What's funny is that while researching I found that a number of people have had similar problems but un-resolved.

    Issue: while attempting to connect the Arduino IDE states that it can't connect (in order to upload the software in accordance with lesson 1F I think.) Earlier in the lesson it states that if the red lights are sequencing (since it doesn't give an example I don't know if it's the same sequencing as what I'm seeing which is dot dot pause... dot dot pause... etc.) that you need to set the board to upload buy moving DIP 1 to on. I did that, but still a no-go. It also won't let me switch to the proper BT port (SLAB_USBtoUART).

    I've attempted multiple cables and USB ports... no fix.

    I've attempted uninstalling ARDUINO and re-installing all software and hardware files... no fix.

    I've attempting uninstalling ARDUINO and going through the SNAP setup... no fix (give me the "board not found" error.

    I'm pretty frustrated. Any help would be very useful. I saw a lady on the FB page had a similar issue while installing SNAP and Arnold asked if she had updated to Sierra recently but he didn't give a possible solution. Which reminds me...

    I also tried uninstalling the USB Driver files and downgrading to Legacy drivers... ya know... just in case... no fix.

    Looking forward to hearing from you.

  • Got it! I see what you mean, "sequencing" can definitely be confusing in this context. I found the lesson, and adjusted the wording so it's clearer. I also called out checking out the video to get a visual idea of what Upload Mode looks like.

    Thanks so much!

  • They were the upload software lessons. For both "Snap!" and Pro. BTW, I just figured out what the "sequencing" of lights refers to... if the blue lights are sequencing the the board isn't set with Dip1 correctly. I would add reference to the blue lights sequencing. Two different problems could be confused by not highlighting with LEDs. Again, I kept trying to solve the "sequencing red light" which, in retrospect, wasn't sequencing, just blinking in a pattern. The problem was solved once I hooked up a data-sync micro-usb.

  • @wedge07 said in Mac Sierra and High Sierra Support:

    there are a couple of steps in the lesson plans that are either unclear or out of order IMHO

    Could you let me know which lesson this is? I want to look into it.

    @wedge07 said in Mac Sierra and High Sierra Support:

    the sparse nature of the Steps didn't clearly indicate it was a necessity

    Could you also let me know which lesson and step this one is, as well?

    I'll re-examine these specific lessons to see how we can improve them. Thank you!

  • Hi @wedge07, glad you were able to sort it out. The cable we package should be able to sync, so the one you had in the box may have been defective. I apologize for the inconvenience! We try to keep defects to a minimum, but some do manage to slip through.

    I'll make sure to look into the issue you mentioned about the lights and sequencing being unclear, as well as clearing up the onboarding process.

    To your last point, we're currently working on a website redesign, which will include a more thorough troubleshooting guide. I'll make sure to include a clearer way for forum users to reach that troubleshooting guide and the documentation.

    Thanks for the feedback!

  • @robolink_wes One more thing... you should include an FAQ and a Troubleshooting Guide pinned on your Community pages. I saw a LOT of troubleshooting related questions with the same response given by a Robolink rep, such as yourself, with no follow-up on the post. If I were King for a day, every solution should be collected, annotated, archived and posted to Troubleshooting Guide. Along with the "what the $%!* do the lights mean!" post.

  • Wes,

    Sorted it out. After a couple of hours additional research, I found that all micro-usb cable are not created equal. The one that came with the CoDrone, for instance, will not allow me to sync. After purchasing a micro-usb cable that specified "for syncing" I had no issues. I don't know if this is a Mac thing (I'm currently using an early 2015 MacBook Pro) or not, but the point is the cable designed to sync had an immediate positive effect.

    Also, there are a couple of steps in the lesson plans that are either unclear or out of order IMHO. The first is the reference to the "sequencing lights" comment on the BLE board. To me, sequencing means some sort of pattern, which, mine would blink twice then pause. As it turns out, that was perfectly OK for communicating with the board. Maybe a link to an explanation of lights (solid red=, green=, yellow= , etc.) would be of some use. Second, one of the reasons I couldn't upload (using the CoDrone Lite lessons... it was a way for me to troubleshoot... break it down to the least number of variables by taking Arduino out of the equation) was that the step to plug the battery in the CoDrone wasn't explicit. So while I had a solid handshake with the BLE, it wouldn't indicate a good connection until the BLE had a good connection with the CoDrone. While it may seem intuitive, the sparse nature of the Steps didn't clearly indicate it was a necessity. I'm trying to see this from the perspective of a 10 year old programming n00b who has been instructed not to get ahead on the steps. So my suggestion is, at the beginning of the lesson, step 1 should be to plug a freshly charged battery into the drone before connecting to the BLE using the properly designed syncing micro-USB cable. 👍

  • Hi @wedge07, sorry you're having issues. Can you paste the exact error message you're getting in Arduino? Also, do you have time to set up a quick video call?

    I want to verify that you've got the 1) board manager installed, 2) selected the proper board, 3) selected the correct port, and 4) installed the CoDrone Library.

    How's your schedule tomorrow (Tuesday)?

Log in to reply

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.