Turn CoDrone On



  • I know! Every video and document I have read says to simply put the battery in and it should power up...but mine doesn't. Occasionally it will flash LED's for a second but then it completely blacks out. Yes, I charged the battery. I then tried to press the calibrate button hoping that would help. It didn't. I also made sure I was in a well lit room without sunlight. At this point, I think it might either be a faulty battery or a faulty drone. I just opened the box, took it out, and tried to run it. Is there anything I'm not doing or am doing wrong? I'm not trying to fly it yet. I never got that far. I just wanted it to power up.



  • Hi @MrsChristianHHS, we may need to replace your CoDrone. Just checking to see if you have time to do a call so we can diagnose.


  • administrators

    Hello @MrsChristianHHS are you available for a video call today or this week? it sounds like your CoDrone has some major issue. Can you send us a video clip using google drive or youtube so we can log it, Thank you!


Log in to reply
 

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.