CoDrone Battery Charging over 40min, still red LEDs

  • Hello, I've been charging the (Byrobot) battery for the CoDrone QuadCopter for over 40 minutes and the two red LEDS are still on. The video on the web says they will turn off when charged. I'm worried. Is this normal to take over 40-minutes?


  • administrators

    @lyakh It sounds like the contacts are failing. Sometimes after a bad crash or months of use, the battery can wear out.

  • The battery is definitely dead. I was able to charge it "fully" again - until the charger LEDs went off, then inserting it half-way the drone went on, but then trying to take off the motors made about 180° and stopped.

  • Thanks for your reply, @robolink_leila No, the battery doesn't look puffy
    But it actually seems to me now that there's a bad contact somewhere. As I've written above I was able to charge it - or at least so I thought - in the morning the lights on the charger were off. But then as I plugged the battery into the drone, it sometimes went on, but then if I just moved the battery a bit it went off. And sometimes it was on when the battery was half-way inserted but went off if I pressed the battery all the way through. And even when the drone was on and I tried to fly it, motors wouldn't turn and the LEDs on the drone would blink - but also not always...

  • administrators

    @lyakh Could you attach a picture of the battery? If it's puffy you may need a new battery.

  • Replying to my own query: I must have forgotten in the months past: the battery has to be charged from a PC, using a complete data USB cable, not just a charger or a charging cable with only power wires. I was looking yesterday and couldn't find it anywhere in the documentation, maybe would be good to make it more obvious and easier to find, assuming my finding is correct.

  • I haven't used my CoDrone for a few months, now I tried to charge the drone battery and I've got the same problem - both charger LEDs stay red. The drone doesn't react when the battery is inserted. Is the battery dead?

  • administrators

    @Dorothy306 ,
    Sometimes the charger will not turn off the LEDs. You can also check the battery percentage in the Petrone App or using code. Do you mind sending a picture of the battery in the charger?

Log in to reply

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.