CoDrone Pro No Bluetooth

  • This is my situation. The previous class departs our lab. We have 4 minutes for class transition. The reading of the daily announcements takes a maximum of 5 minutes. What this means is that that if I avoid my hall supervision, I have roughly 9 minutes to get the drone connected to the computer and ready to program. My problem is that I have never been able to get it connected in less than 30 minutes. If I cannot get this connected in under 9 minutes, it is of no use to me. I am running Windows 10 as an OS. Here are the steps I have tried.
    I installed Python 3.7
    ![alt text](0_1549400168422_error1.png
    I opened the command prompt as an administrator and used the
    pip install –upgrade pip
    I typed the next command of
    python –m pip install jupyter
    I start the jupyter notebook.
    jupyter notebook
    I select the new Python 3 menu.
    I downloaded and installed the driver.
    I extracted the zipped files.
    I ran the executable file.
    Using Jupyter, I installed CoDrone.
    The UART cable is disconnected, the USB cable is connected to my computer and the BLE LED is blinking red. I connected the CoDrone battery and ran this code.
    I have previously had it connected to this computer, but I do not know why it connected. I repeated this same process 4 times and on the 4th time it connected. I shut down the computer, did a restart, and it would not connect again. On the second attempt at connection, I started at running Jupyter Notebook and trying to connect. It would not connect. I ran through the entire installation process and it would not connect. Can anyone find an issue with my installation sequence?

  • administrators

    @rcase35 It may the case that you need to continue to connect to that port if you are on a desktop computer. Keep me updated!

  • @robolink_leila
    I had tried all three USB ports on the front of the computer. I moved it to the back of the computer to the USB ports that are soldered to the motherboard and it worked. I will test again later today and keep my fingers crossed.

  • administrators

    Hi @rcase35 ,
    Since you are using Windows there is a way to check which COM port the device is connected to. Navigate to your Control Panel >Devices and Printers> Device Manager. From the menu, select the "Ports" drop-down menu and look for the correct port. It will never be on COM1 so it should the other available port. Once you have this information you can open the port manually in the code. For example, if your BLE board shows up on COM3:

    drone.pair(drone.Nearest, 'COM3')

    It seems like your connection worked before. Did you ever change the USB cable or try plugging it in a different USB port?

Log in to reply

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.