Codrone Improperly executing movement commands

  • Hello, my name is Parsa and I am a student in grade 12. For the past semester in school, my group mates and I have been working on using the FPV module and computer vision to guide the drone through our school. In the last couple of weeks we have ran into several issues with the movement commands. An example would be that if we use the command "drone.takeoff()", the drone will move upwards and then sway to random directions. After basic calibration did not work, we tried to correct the issue using trim values, but we find that the values we have to correct for varies for the battery that we use. We have also tried changing motors on the drone, but this has not helped the drone fly more stably.

    A response would be greatly appreciated.

  • Good evening, Parsa. After discussing the problem further with my coworkers, it would perhaps be best if we attempt to troubleshoot the problem via video call. If it's not too inconvenient, would you like to schedule one? Available times are Monday to Thursday, starting from June 20 onwards.

  • @superduperguy *Latest version of the python library

  • Thank you for the reply Michael. I have tested the quality of the batteries, and most of them appear to be good. I have checked the motor orientation on the drone and ensured that they are correct.One thing that is curious to me is that using the Petrone app we were able to make the drone fly stably for a single run. However in subsequent runs it no longer properly executed movement commands. Changing the battery on the drone did not help. We are using the latest version of the Codrone library found on Github.

  • Good evening, Parsa. After running some tests, there may be several reasons why your drone is no longer flying properly. Although you did mention changing the motors, I'd still recommend checking this video, which covers some common issues, including motor and propeller orientation, and hardware connections.

    Other reasons for why the motors may not be functioning properly may be due to the battery itself; it's possible that your battery may not be running at maximum capacity, which can be determined by seeing if it has started to puff out. You can test this by removing the battery and placing it on a flat surface, sticker-down. Press down on one end of the battery and see if it rocks back and forth. If so, your battery has started to puff out, and thus the drone is unable to achieve maximum power.

    Please let us know which of these methods you tried, including which version of the CoDrone library you are using, and we would be assist to help you further.

Log in to reply

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.