Bluetooth connection issue

  • Global Moderator

    Customer Question: I am hoping you might have some support help to offer for the issue i'm experiencing. The bluetooth board does not connect properly (according to RBcodrone 1.1.3 beta). The Chrome app seems to recognize whether it's blinking orange/green, or blinking red in pair mode. It fails to pair however. I have followed your installation and setup guide to the point where the software requests a connection (pair) with the CoDrone flyer. I am unable to update any of the firmware; according to the RBCoDrone Software. If i can't get this to work, I am at a loss. Unfortunately this was a christmas gift and I believe we are past the return duration. Can you please help?

    My system; Mac 13-inch mid-2010, 2.4ghz intel, 16gb ram, OS 10.11.5.
    RBCoDrone 1.1.3 beta installed on local hardrive, and also installed as an App In Google Chrome 64.0.3282.167 (Official Build) (64-bit). Neither reach a connection with the bluetooth board.

  • hurray

  • @robolink_wes I was able to connect and pair the drone as you suggested. I finally received the connection message. Thank you!


  • Ah, okay, that's a bug we're working on resolving right now. It's actually a false alarm.

    In that situation, I believe if you hit "Cancel," the red box at the top of Snap will actually list out the CoDrone you're connected to. Essentially, it's hanging up on an incomplete package that isn't actually necessary to be connected. So can you hit Cancel, and see if the red box at the top of the application is showing you as connected?

  • Thanks for the quick reply @robolink_wes. I did what you said however it still didn't fully work. After opening Snap! it was able to detect the drone, but I still could not pair (see attached images)



  • Hi @vette99! We've seen this issue when people who have the Pro use the remote to run Snap. So when you connect the fully built remote to run Snap, what happens is the BLE board itself, will go into "talking to the Smart Inventor board" mode rather than "pairing with a CoDrone" mode when it is plugged in to the Smart Inventor Board (the board in the grey clear plastic). So you'll need to disconnect the UART cable from the BLE board, which is the cable that has white plugs on both ends, and 4 black thin cables in the middle. Unplug it from the bottom left of the rectangular BLE board.

    Once you've unplugged it, make sure that the LED is blinking red, as well, so that the board is in pairing mode. You can do this by clicking the tiny button above the LED light, until it's red, and blinking.

    Let me know if this works, or if you're still having trouble. We can further help troubleshoot.

  • Hello, I am having a similar issue. I purchased a coDrone pro and want to run Snap to allow my kids to program. However, when I attempt to connect the bluetooth board to the computer and start Snap I can neither get the drone to pair or update the drone. If I unhook the bluetooth device from the computer and just turn on the remote, both the drone and remote will pair.

    I have tried this on my Mac and a Windows laptop without success. Suggestions?

    I have also looked at this post, but still no success.

    My Systems:
    MacBook Pro 15in, 2016
    2.7 GHz, Intel Core i7
    16 GB Ram
    OS 10.12.6

    Dell Precision M3800
    Intel Core i7
    16 GB Ram
    Windows 10 Pro

  • Global Moderator

    Yes, thanks! I've done it already.

  • @robolink_hansol Can you forward the original message to @robolink_arnold so he can contact this customer directly and try to resolve the issue?

Log in to reply

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.