Ports Greyed Out



  • I have downloaded all the software and drivers for Arduino, but when I go to select the port to upload code, "port" is greyed out, and I cannot click on it. I have tried this on multiple computers (mac and pc) with multiple cables. Please respond ASAP for a fix. Thanks!



  • Good afternoon. This is Michael from Robolink.

    Based on what you've described in an email I received, it would appear that the CoDrone is not being recognized by your computers, which would indicate that there is either a problem with the USB connection, or there is a problem with the CoDrone BLE board itself. You've said you've used multiple computers and USB cables, which rules out a number of causes, but there are still a few more troubleshooting suggestions I'd like to offer, if you don't mind:

    Basic suggestions:

    1. Are you using USB 3.0 ports or a USB hub to connect to the CoDrone? Sometimes those can be incompatible with hardware.

    Advanced suggestions:

    1. On the Mac, you may need to install the legacy version of the driver before the board can be recognized. When mounting the .DMG file, one of the folders that will appear is called "Legacy MacVCP Driver". Install the driver from this folder.
    2. Does the computer you're using respond to the CoDrone board when it's plugged in (sound, notifications, etc.)? If you're on Windows, you can unplug the CoDrone and go into the Device Manager (Windows Key + R > Type "devmgmt.msc" > OK). When you plug in the CoDrone while Device Manager is open, it should refresh and a new option should appear under the section "Ports" as "Silicon Labs CP210x USB to UART Bridge". If it appears in Device Manager as a generic "USB Device", then that could mean that the CP210x driver was not installed properly.
    3. What LED color/pattern appears on the CoDrone BLE board when it's plugged in? Normal combinations are a flashing yellowish light, or a flashing red light. Any other color/pattern could be an indicator that you have a defective board.

    Regardless, it would be best to schedule a video call with one of our regular CoDrone support staff. You should be receiving an email regarding this shortly.



  • @robolink_michael said in Ports Greyed Out:

    CP210x driver

    1. I am not using a USB 3.0 port.
    2. I'm not currently using a Mac.
    3. a. I have never received any sound or notifications from my CoDrone board. b. There is no "ports" option in my Device manager (see pic in link below). c. I have already successfully installed the CP@10x driver multiple times (see pic in link below).
    4. The color patterns on my board are flashing blue and pulsing yellow.

    https://docs.google.com/document/d/1e0vhcMLdZSidoubV4XFefIRmxmGxv4GDbnhvQd-EkMk/edit?usp=sharing


  • administrators

    Hello @dmars2001 I am trying to access the photos in order to assist you but it looks like I need permission.
    If the color pattern is pulsing yellow you may need to follow the steps in this video https://www.youtube.com/watch?v=K4A2bkAxh3Y the color pattern you should get is the one at 1:11 in the video.


  • administrators

    @dmars2001 I’ve looked at the images and I can see you have installed the silicon labs driver properly. Do you mind posting a picture of the CoDrone remote controller wiring and a screenshot of the Arduino IDE as you are trying upload?

    Also, what kind of computer are you using? And what windows operating system are you running?


  • administrators

    @dmars2001 Step 9 of this lesson goes over how to do the Mac installation for the driver. What version of Mac OS are you running? You might have to do it twice. I hope this helps.


Log in to reply
 

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.