Bad program execution CoDrone Line Blockly

  • In between program step the propeller stop and start:
    Example of behavior:

    1. Take Off
      Propellers start drone lift off.
    2. Hover 5 seconds.
      Drone hovers propeller all OK.
    3. Move forward 1 second.
      All propellers shut down for 1 second.
      All propellers start up and drone scoot forward across the floor for 1 second.
    4. Land
      All propellers shut down for 1 second.
      Propeller turn all then turn off.

  • I thought about the battery. Same result with fully charged battery.
    Also, same program, with same commands worked the day before.
    I have tried all combinations to try and determine issue.
    i.e. Hover with 100% power. Still shuts off in between commands.
    Behavior is like program command steps execution is slow to load next step and during the step load/setup process the motor is shut off.

    I am returning the drone. Have already put in enough time troubleshooting a brand new piece of equipment. Worked beautifully out of the box. Next day worked for about 1st hour then issues. First major drifting, then propeller shutdown in between program commands.

    I am open to another try of your product once you resolve your quality/reliability issues.

  • administrators

    Hi @ronbolts ,
    It sounds like your CoDrone is running low on battery, but just to be sure can you attach a screenshot of your code? If you are experiencing skipping commands, try including a wait block for half a second to a second between your move commands. Let me know if this still does not resolve the issue!

Log in to reply

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.