Zumi Camera not working

  • Hello,
    after having a talk with a awesome coworker of RoboLink we were finally able to update to 2.31.
    Now I tried to work with the camera.

    When starting drive mode it shows: "Camera may not be connected"

    When trying the QR-Code-Course for example and trying to start the camera it shows the following message:
    Starting PiCamera

    PiCameraMMALError Traceback (most recent call last)
    /usr/lib/python3/dist-packages/picamera/camera.py in _init_camera(self, num, stereo_mode, stereo_decimate)
    455 try:
    --> 456 self._camera = mo.MMALCamera()
    457 except PiCameraMMALError as e:

    /usr/lib/python3/dist-packages/picamera/mmalobj.py in init(self)
    2278 global FIX_RGB_BGR_ORDER
    -> 2279 super(MMALCamera, self).init()

    /usr/lib/python3/dist-packages/picamera/mmalobj.py in init(self)
    632 mmal.mmal_component_create(self.component_type, self._component),
    --> 633 prefix="Failed to create MMAL component %s" % self.component_type)
    634 if self._component[0].input_num != len(self.opaque_input_subformats):

    /usr/lib/python3/dist-packages/picamera/exc.py in mmal_check(status, prefix)
    183 if status != mmal.MMAL_SUCCESS:
    --> 184 raise PiCameraMMALError(status, prefix)

    PiCameraMMALError: Failed to create MMAL component b'vc.ril.camera': Out of memory

    During handling of the above exception, another exception occurred:

    PiCameraError Traceback (most recent call last)
    <ipython-input-2-128cc1752c2b> in <module>
    ----> 1 camera.start_camera()
    2 try:
    3 for i in range(50):
    4 frame = camera.capture()
    5 vision.find_QR_code(frame)

    /usr/local/lib/python3.5/dist-packages/zumi/util/camera.py in start_camera(self)
    59 return
    60 print('Starting PiCamera')
    ---> 61 self.camera = PiCamera() # PiCamera gets resolution (height, width)
    62 self.camera.resolution = self.resolution
    63 self.camera.framerate = self.framerate

    /usr/lib/python3/dist-packages/picamera/camera.py in init(self, camera_num, stereo_mode, stereo_decimate, resolution, framerate, sensor_mode, led_pin, clock_mode, framerate_range)
    429 raise PiCameraValueError('Invalid clock mode: %s' % clock_mode)
    430 try:
    --> 431 self._init_camera(camera_num, stereo_mode, stereo_decimate)
    432 self._configure_camera(sensor_mode, framerate, resolution, clock_mode)
    433 self._init_preview()

    /usr/lib/python3/dist-packages/picamera/camera.py in _init_camera(self, num, stereo_mode, stereo_decimate)
    458 if e.status == mmal.MMAL_ENOMEM:
    459 raise PiCameraError(
    --> 460 "Camera is not enabled. Try running 'sudo raspi-config' "
    461 "and ensure that the camera has been enabled.")
    462 else:

    PiCameraError: Camera is not enabled. Try running 'sudo raspi-config' and ensure that the camera has been enabled.

    I already tryed it like 3 times and also checked the camera cables on the board.


  • administrators

    @timmytomate Great! Sometimes you just need to close the camera and reboot Zumi. Let us know if you have any further issues!

  • thx for the quick response. Somehow it actually worked afterwards. I thought i had checked it before properly.

  • administrators

    @timmytomate ,
    It seems like the camera may be disconnected underneath the shell in the front (the Sunny connector). Please reference this FAQ for an image. Then, restart Zumi and check if the camera is enabled.

Log in to reply

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.