Purple blinking light on BLE board



  • The codrone lite will pair, but when you try to make it do something, BLE blinks purple???


  • Global Moderator

    Hi @klaus: Thank you very much for your inquiry. Do you mind uploading video or picture of this? We will address it right away.


  • administrators

    Hello @klaus do you mind posting your code?



  • I'm sorry I'm not very good at this stuff yet. I was just using the block code to have it lift off and then land. I have 4 of these same drones and the rest are functioning normally. This one seemingly pairs normally. Then when I click the "when green flag clicked" block to start... the light on the BLE board flashes purple one time. The drone never responds.



  • Ok so I've checked the blades, checked the connections on each motor, changed out the motors one by one. The bluetooth is communicating because I can change the LEDs on the drone. It just won't fly. The blades have never turned.
    And while I'm not great at this sort of thing, the other 3 I bought are working fine. I'm thinking this just needs replaced. It has never worked!!!


  • administrators

    Hello @klaus would you be available for a video call? I can help troubleshoot the issue. Can you try flying that specific CoDrone using the petrone app. You will find some helpful info here and the link to the petrone app.



  • I am doing this at school and we are in the middle of state testing for a few weeks. I will get back with you when I can find a time to do a video call. Thanks for responding.


Log in to reply
 

Looks like your connection to Robolink community was lost, please wait while we try to reconnect.