@joe We have removed support for Snap! and we have officially transitioned to Blockly because the drivers are not compatible with Chromebooks. Blockly is compatible with MacOS, Windows, and Chromebooks and you do not need the BLE board. All of our setup information and lessons can be found here!