@patrick-huber Unfortunately, the latest release of Catalina is no longer compatible with our board 😞 We are currently working on updating our firmware so that it is compatible, and we will let you know once we have an update! In the meantime, you would need to downgrade Catalina to 10.14 or use a Windows machine to program the SmartInventor board with Arduino. You can also avoid using the SmartInventor board by following our tutorials for programming with Python. We apologize for the inconvenience but we are addressing the issue. Thank you!